[Accessibility] AT-SPI dependencies

Olaf Schmidt ojschmidt at kde.org
Wed Nov 15 13:43:22 PST 2006


Hi!

This is a list of at-spi dependencies on Kubuntu 6.06.
Can someone else do a similar check on other distributions?

I left out those that are already in the LSB.

Necessary:
        libORBit-2.so.0
        libORBitCosNaming-2.so.0

Deprecated:
        libbonobo-2.so.0
        libbonobo-activation.so.4

Maybe unnecessary:
        libgailutil.so.17
        libgthread-2.0.so.0
        libexpat.so.1 (XML parsing C library)
        libpopt.so.0 (library for parsing command line parameters)

Totally unrelated to accessibility (maybe distribution specific):
        libgnomecanvas-2.so.0
        libart_lgpl_2.so.2
        libpango-1.0.so.0
        libcairo.so.2
        libpangocairo-1.0.so.0

        libfontconfig.so.1
        libfreetype.so.6

Additional X libraries: (Which of these are required for accessibility?)
        libXrender.so.1
        libXinerama.so.1
        libXrandr.so.2
        libXcursor.so.1
        libXfixes.so.3
        libXtst.so.6
        libXau.so.6

The list is far too long. Some distributions (e.g. Kubuntu) ship on a single 
CS, and this amount of libraries would mean to sacrifice several user 
applications.

I am sure that some of the dependencies are distribution specific. But it is 
also possible that we depend on newer versions of standardised libraries, 
which would make the list longer again.

Olaf




More information about the Accessibility mailing list