[Bitcoin-development] Lying about User Agent (was: BIP language on normative behavior)

Luke-Jr luke at dashjr.org
Mon Dec 19 22:36:44 UTC 2011


On Monday, December 19, 2011 5:29:34 PM Gregory Maxwell wrote:
> I've been arguing with Luke-JR on IRC about the interpenetration of
> BIP_0014—  Gavin's recent commit uses the same version string for the
> GUI interface and the daemon mode.
> 
> Luke believes this is a _violation_ of BIP_0014 and an error in
> judgement on Gavin's part, and a failure to conform to the community
> adopted standard. 

To clarify, I believe LYING about the client is a violation. Specifically, 
Gavin's commit intentionally reports "bitcoin-qt" for bitcoind. A common name 
for the codebase is compliant, and I don't see anything that says a version 
*must* be reported at all, let alone for a specific component, so it *could* 
comply by leaving that part off. But if there is a common part, it certainly 
isn't Bitcoin-Qt.

https://github.com/bitcoin/bitcoin/pull/715 contains a fix that should fulfil 
everyone's desires (Gavin wants security by obscurity by making bitcoind and 
Bitcoin-Qt indistinguishable; this is the default with pull #715).




More information about the bitcoin-dev mailing list