[Bitcoin-development] Anyone still using SOCKS4?

Wladimir laanwj at gmail.com
Wed Jun 11 15:39:51 UTC 2014


Hello all,

Is anyone using a SOCKS4-only proxy with Bitcoin Core? SOCKS5 was
introduced in 1996, so there is hardly an excuse to not support it.

If no one screams fire, we plan on removing support for it in the next
major release, for two reasons:

- It would remove some crufty, hardly tested code paths

- SOCKS5 offers better privacy as it allows DNS redirection

Wladimir




More information about the bitcoin-dev mailing list