[bitcoin-dev] Planned Obsolescence

Alice Wonder alice at librelamp.com
Sun Dec 18 20:07:36 UTC 2016


On 12/14/2016 07:38 PM, Juan Garavaglia via bitcoin-dev wrote:

>
> For reasons I am unable to determine a significant number of node
> operators do not upgrade their clients.

I almost did not update to 0.13.0 because the test suite was failing due 
to python errors. How to fix them was posted on bitcointalk.

0.13.1 came with new python errors in the test suite. So I just said 
fuck it.

When the test suite actually works in my fairly standard environment 
(CentOS) in the distributed release, I will upgrade.

Until then, I'm not jumping through hoops to make the test suite work 
and I'm not running clients that haven't passed the test suite so that's 
why I almost didn't update to 0.13.0 and haven't updated since.


More information about the bitcoin-dev mailing list