[Bridge] RH 9 problems iptbles + bridge

Hakan Stensby hst at nsc.liu.se
Fri Dec 19 07:37:58 PST 2003


I just want to say that the bridge works as it should now. Patched it with
http://bridge.sourceforge.net/devel/bridge-nf/bridge-nf-0.0.7-against-2.4.19.diff
then recompile... works just as it should.

Thanks again!

Merry Christmas everyone.

//håkan
On Thu, 18 Dec 2003, Hakan Stensby wrote:

> Ah, so the bridge module shipping with rh kernel dont have support for iptables, 
> that explains it all :D
> and it was very stupid of me to think that the one thing that at least I would 
> like to use with the bridge must be patched in :D
> 
> Shouldnt be a problem to build the kernel myself, last time it went very 
> smoothly!
> 
> Thanks!
> 
> 
> On Thu, 18 Dec 2003, Bart De Schuymer wrote:
> 
> > On Thursday 18 December 2003 09:46, Hakan Stensby wrote:
> > > Hi,
> > >
> > > I've been running RH 7.2 with a kernel-2.4.9-13brnf0.0.3 for a very long
> > > time and works just fine.
> > >
> > > A couple of weeks ago I thought I'd install a new fresh installation with
> > > rh9 and load the bridge module that comes with the rh kernel ( 2.4.20-24.9
> > > ).
> > >
> > > The bridge itself works just fine but the firewalling dont.
> > > There is no packets passing the FORWARD chain... Have I missed something
> > > really essential here?
> > > The same iptable script works just fine on the old box...
> > 
> > You forgot to apply the appropriate bridge-nf patch, see 
> > ebtables.sourceforge.net.
> > 
> > cheers,
> > Bart




More information about the Bridge mailing list