[Bridge] Sparc64 bug in 1.0.4

Micah Anderson micah at riseup.net
Tue Aug 3 18:02:30 PDT 2004

Under sparc64, with the bridge module loaded, running brctl addbr br0
results in:

add bridge failed: Operation not supported
sys32_ioctl(brctl:6667): Unknown cmd fd(3) cmd(000089a0) arg(effffbf9) 

This was a known problem to the debian sparc list, and someone offered
a work-around back in April to an older version of bridge-utils (0.9.6), you
can see that thread here:


Looking at the changelog for the bridgeutils upstream, it appears as 
if there have been some attempts to fix this, but it doesn't seem to

I tried to do the "hack" that is suggested in that thread, which is
impossible in the newest source, so I used the 0.9.6 source. That did
indeed allow me to brctl addbr br0, but if I tried to do anything
else, brctl did not know of any bridges (brctl show showed nothing,
although the interface existed).

ugh... thanks for any help (please cc me on any replies),

More information about the Bridge mailing list