[Bridge] Queries about Bridging

Jonathan Thibault jonathan at navigue.com
Mon Jun 23 06:44:52 PDT 2008


You normally should not assign an IP address (or dhcp) to the member 
interfaces, only the bridge interface.

Sibu Thomas Mathew wrote:
>
> Sir,
> I shared internet on a LAN using my machine. It has got two ethernet 
> cards. I installed Ubuntu 8.04. I did the bridging using 
> "bridge-utils". Even though it turned out to be successful, I came 
> across certain other problems:
> 1) I couldn't use the internet using my machine.
> 2) After every restart, I had to redo the whole bridging configuration.
>
> This is how i configured.
> The two ethernet cards are eth0 and eth1. eth1 is the one connected to 
> the internet. This is what I typed:
>     brctl addbr br0
>     brctl addif br0 eth0
>     brctl addif br0 eth1
>     ifconfig br0 up
> Then i edited the /etc/network/interfaces as follows:
>     auto lo
>     iface lo inet loopback
>
>     iface eth0 inet dhcp
>
>     auto eth1
>     iface eth1 inet dhcp
>
>     auto br0
>     iface br0 inet dhcp
>
> After that i restarted the service by typing
>         /etc/init.d/networking restart
> The bridging worked. The client machine could access the internet 
> except mine i.e. the server. Where did I go wrong? What can I do to 
> solve this.
>
> Looking forward for a solution.
> Thanking you.
>
> Yours sincerely,
> Sibu Thomas Mathew
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Bridge mailing list
> Bridge at lists.linux-foundation.org
> https://lists.linux-foundation.org/mailman/listinfo/bridge



More information about the Bridge mailing list