[Bridge] Bridge troubles

Friedrich Dominicus frido at q-software-solutions.de
Wed Jun 25 01:38:48 PDT 2008


Stephen Hemminger <shemminger at vyatta.com> writes:

> On Tue, 24 Jun 2008 16:11:36 +0200
> Friedrich Dominicus <frido at q-software-solutions.de> wrote:
>
>> I'm sorry to bother you but I'm stuck
>> 
>> I can not make a bridge work for me. 
>> My current configuration is:
>> eth0      Link encap:Ethernet  Hardware Adresse 00:1d:7d:d1:06:bd  
>>           inet Adresse:192.168.1.1  Bcast:192.168.1.255  Maske:255.255.255.0
>>           inet6-Adresse: fe80::21d:7dff:fed1:6bd/64
>> Gültigkeitsbereich:V
>> 
>> according to all what I could find in the net. The following should do
>> to build a bridge 
>> ifconfig eth0 down
>> # brctl addbr br0
>> # addif br0 eth0
>> # ifconfig eth0 0.0.0.0 up
>> # ifconfig  br0 192.168.1.1 up
Ok, I tried exactly the same on  32-bit linux and there this simply
runs.

So I have to conclude that this either is a problem in my 64-bit machine
setup (however I tried on a different 64-bit platform with the same
result) 
Of that there is some bug on a 64-bit platform

Regards
Friedrich





More information about the Bridge mailing list