[Bridge] Linux Ethernet bridge and UPNP

Sebastian Niehaus niehaus at nospam.arcornews.de
Sat Jan 23 02:38:45 PST 2010


I have a linux box (Debian Lenny) with a bridged ethernet
interface. The box is running mediatomb[1], an UPNP media server.

If I run gupnp-universal-cp (a tool to discover UPNP-Devices in the
network) on this computer I only see the mediatomb server on the same
maschine but no other UPNP-Devices.

If I run gupnp-universal-cp on another computer in the network
(without ethernet bridge) I see other UPNP-Devices in the network but
not the media server.

All boxes are in the same subnet and networking gererally works
fine. The media server's web interface can be reached from any
computer in the network but UPNP discovery does not work.

Are there know issues with ethernet bridging and
UPNP/(multicast?)-traffic? Is there hint how I might resolve my
problem that mediatomb is not "UPNP-visible" in the network?

Thanks in advance,


[1] http://mediatomb.cc/

[2] http://www.gupnp.org/

More information about the Bridge mailing list