[Bridge] netconsole breaks netpoll on bridge

Cong Wang cwang at twopensource.com
Mon Jun 16 19:12:06 UTC 2014


On Mon, Jun 16, 2014 at 12:05 PM, Stefan Priebe - Profihost AG
<s.priebe at profihost.ag> wrote:
>
>> Am 16.06.2014 um 20:51 schrieb Cong Wang <cwang at twopensource.com>:
>>
>> On Mon, Jun 16, 2014 at 11:41 AM, Stefan Priebe - Profihost AG
>> <s.priebe at profihost.ag> wrote:
>>>
>>>> Am 16.06.2014 um 20:05 schrieb Cong Wang <cwang at twopensource.com>:
>>>>
>>>> On Mon, Jun 16, 2014 at 5:51 AM, Stefan Priebe - Profihost AG
>>>> <s.priebe at profihost.ag> wrote:
>>>>> Hi,
>>>>>
>>>>> i'm using a vanilla 3.10.43 kernel and netconsole on top of a bridge.
>>>>>
>>>>> netconsole is used with vmbr0 (bridge) which is on top of bond0.
>>>>>
>>>>> If i want to add another bridge to vmbr0 is fails as long as netconsole
>>>>> is in use.
>>>>>
>>>>> # brctl addif vmbr0 fwpr2004p0
>>>>> can't add fwpr2004p0 to bridge vmbr0: Unknown error 524
>>>>>
>>>>> Kernel output:
>>>>> netpoll: (null): fwpr2004p0 doesn't support polling, aborting
>>>>>
>>>>> If i do rmmod netconsole - everything is working fine again.
>>>>
>>>> This is expected, you can't add an interface which doesn't support
>>>> netpoll to a bridge which is running netpoll.
>>>
>>> Thanks, so i can't use netconsole at a bridge used for vms?
>>
>> You can, but you need to make sure all the devices under
>> this bridge support netpoll. Not considering mac learning,
>> bridge just broadcasts all the packets to its ports, if one of them
>> doesn't support netpoll, how could it work?
>
> Ok i was trying to add a veth device so this is the problematic device.
>

We can just add netpoll support to veth device, it should not be hard.
I will work on it once net-next is open.

Thanks.


More information about the Bridge mailing list