[Bugme-new] [Bug 8987] New: IXP SB400 can't see the DVD drive if there's a harddisk on the cable

bugme-daemon at bugzilla.kernel.org bugme-daemon at bugzilla.kernel.org
Fri Sep 7 02:30:00 PDT 2007


           Summary: IXP SB400 can't  see the DVD drive if there's a harddisk
                    on the cable
           Product: Platform Specific/Hardware
           Version: 2.5
     KernelVersion: FC6 latest:
          Platform: All
        OS/Version: Linux
              Tree: Fedora
            Status: NEW
          Severity: normal
          Priority: P1
         Component: i386
        AssignedTo: platform_i386 at kernel-bugs.osdl.org
        ReportedBy: steve at tallyho.bc.nu

Most recent kernel where this bug did not occur: Unknown
Distribution: FC4
Hardware Environment: ATI 437A and 4379 SATA controllers, plus "Standard Dual
Channel PCI IDE Controller ATI (rev 80) (prog-if 82 [Master PriP])" driving
just a single PATA interface
Software Environment: FC6, Kernel (no binary NVIDIA drivers
Problem Description: With just a DVD drive on the PATA interface (configured as
slave as it happens) there's no problem. Add a HD (configured as master,
obviously) and the HD runs fine (DMA seems to be working, 53Mb/sec reported
from 'hdparm'). However, the DVD drive is now unavailable. "Dmesg" does report
initially spotting the DVD drive: "hdb: PHILIPS DVDR1628P1, ATAPI CD/DVD-ROM
drive", but then reports a couple of "drive not ready" errors and that's the
last you see of it.

Steps to reproduce: See above, but I've also tried swapping the
plugin-positions of master and slave on the cable (no effect) and changing the
"UDMA100" cable for a boring old-fashioned "coarse pitch" cable. This halved
the bandwidth to the HD to about 26Mb/sec, but otherwise no effect.

Not tried: running the DVD drive as master, HD as slave.

I have tried configuring the DVD drive to turn off the DMA. 'hdparm' initially
reports "DMA on" for the drive, and allows you to set it to "off" but then
won't let you turn it on again. Tried setting the DVD drive to work in PIO
mode, but still no joy.

Noticeable other effects: "udev" gets stuck for several minutes in the boot-up
sequence when the HD is present. Remove the HD and "udev" has no trouble.

Other notes: looks like Windows XP has a problem with this configuration too,
but it (eventually) recovers and can at least use the DVD drive after several
minutes delay after boot up. Can't tell if XP can see the HD on the PATA
interface - there happen to be no windoze partitions on it.

Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the Bugme-new mailing list