[cgl_discussion] v2.5 TIPC TODO list

Mika Kukkonen mika at osdl.org
Thu Mar 13 09:44:35 PST 2003

These are the "janitoring" items mentioned in PoC that I would be 
grateful if somebody would look into, listed in some order of
preference (remember, I am talking about my code, not Jon's):

	0) Currently message sending does not work
		- probably macro issue
	        - Mark is looking into this

	1) Spurious printk's to the console:
             - bloody annoying
	     - fix is to replace every printf* from the code
	       with the err(), warn(), info(), and dbg()
	     - Mark is planning to look into this too, so
	       talk with him first

	2) Decoupling of dbg_buf, stats_buf and shutting down
	   the raw bearers:
	     - currently if you turn off TIPC_DBG_BUF you lose
	       statistics and more importantly shutting down
	       the raw bearers
	     - I have my doubts about the usability of the whole
	       dbg_buf concept, but at least currently plan is not
	       to diverge on functionality, so it should stay
	     - I partly started separation of dbg_buf and stats_buf,
	       but code duplication is annoying
	     - Mark is planning to look into this too, so
	       talk with him first

	3) Cleaning up version 0 message support, i.e. compat_msg.h
	   and compat_msg.c files:
             - reasonable small job with very independent part of TIPC

	4) Cleaning up resto of old module handling stuff:
	     - all code realating to Linux modules should be in
	       driver.c, but there is still at least some 
	       MODULES_USE_COUNT lying around

	5) Bottom handler stuff and msg_buf (msg_buf.h and handler.c):
	     - there is some wierd stuff going there and then I doubt
	       the queuing stuff is rock solid, but I am very afraid
	       to touch the code because it can potentially break
	       TIPC very badly

	6) Getting rid of C++ naming scheme:
		- tipc_fooBar => tipc_foo_bar
		- typedef struct FooBar {/*...*/} FooBar;
		  => typedef struct foo_bar {/*...*/} foo_bar_t;

	7) Replacing long macros (#define foo() with several lines
	   of code) with static inline's
	        - plenty of those ...

	8) Renaming stuff. i.e. the term mapping:
	     - The map is from top to bottom:
		  TIPC (Jon's code)	v2.5 TIPC
		  =================	===========
		  Network		network
		  Zone			zone
		  Subnetwork		cluster
		  Manager		manager
		  Processor		worker
		  Device Processor	slave
	     - This really is not very important, and is better done
	       when you are doing modifications anyway to the code

Please note that I am still far from happy with filenames, and will bhe
changing them, so I would suggest you pick one file, do changes, and
sync them (= send patch) with me ASAP. My plan is put an update at least
once a week to http://www.osdl.org/archive/mika/.



More information about the cgl_discussion mailing list