[cgl_discussion] Re: RE: [Fwd: hotswap and CGL (fwd)]

Greg KH greg at kroah.com
Fri May 2 09:45:57 PDT 2003


On Wed, 30 Apr 2003 14:14:23 -0700, Steven Dake wrote:
> I could be wrong, but MontaVista is the only linux vendor making
> available compact PCI hotswap support in linux 2.4.

Not true, the same cpci code that is currently in the 2.5 kernel is
offered as a patch for 2.4.  The only reason it isn't in the main kernel
tree is a lack of time by the author to fix up a few small things some of
the kernel developers wanted, but that's no reason why any distro
shouldn't add it.

The added bonus of Scott's 2.4 cPCI patch is that it works with the
existing PCI Hotplug framework and userspace tools, unlike MontaVista's
implementation :)

thanks,

greg k-h




More information about the cgl_discussion mailing list