[PATCH 14/25] sysfs: Don't use lookup_one_len_kern

Tejun Heo htejun at gmail.com
Wed Aug 8 08:35:39 PDT 2007

Eric W. Biederman wrote:
>> right?  I don't think we need to duplicate the code here.  Or is it
>> needed for later multi-sb thing?
> Right.  We can do that as well. In practice in working code
> there is no real difference.
> There is a little extra uniformity in rolling it ourselves, but
> not enough to worry about either way.
> In the review/debug etc cycle it just wound up being a lot easier
> to roll the code myself.
> By the time we get to lookup_one_len_kern it is almost impenetrable
> code in namei.c where sysfs_add_dentry tends is easier to comprehend,
> and to modify for debugging.

Yeap, agreed.  I agreed with this one too in the comment for the next
patch.  I guess I should have wrote here too.  Sorry about the trouble.



More information about the Containers mailing list