[RFC][PATCH 1/2] split up shrink_page_list()

Dave Hansen hansendc at us.ibm.com
Thu Jun 14 10:17:46 PDT 2007


On Thu, 2007-06-14 at 11:00 -0500, serue at linux.vnet.ibm.com wrote:
> Quoting Dave Hansen (hansendc at us.ibm.com):
> > 
> > This patch takes shrink_page_list() and splits out its main
> > loop into another function: try_to_shrink_page().  I think
> > this makes it all a bit more readable.
> 
> Haven't checked every error path yet, but it looks correct enough
> to these mm-virgin eyes.
> 
> Why is try_to_put_page_in_swap() defined in this patch?  Is that
> on purpose?

It should really go in the other one.

-- Dave



More information about the Containers mailing list