[RFC v17][PATCH 16/60] pids 6/7: Define do_fork_with_pids()

Serge E. Hallyn serue at us.ibm.com
Mon Aug 3 11:26:40 PDT 2009


Quoting Oren Laadan (orenl at librato.com):
> From: Sukadev Bhattiprolu <sukadev at linux.vnet.ibm.com>
...
> +struct target_pid_set {
> +	int num_pids;
> +	pid_t *target_pids;
> +};

Oren, I thought you had decided to add an extended flags field
here, to support additional CLONE_ flags - such as CLONE_TIMENS?

I mention it now because if you're still considering that
long-term, then IMO the syscall should not be called clone_with_pids(),
but clone_extended().  Otherwise, to support new clone flags we'll
either have to use unshare2 (without clone support), or add yet
another clone variant, OR use clone_with_pids() which is a poor name
for something which will likely be used in cases without specifying
pids, but specifying flags not support through any other interface.

-serge


More information about the Containers mailing list