BUG in tty_open when using containers and ptrace

Sukadev Bhattiprolu sukadev at linux.vnet.ibm.com
Tue Jul 21 23:41:20 PDT 2009

Grzegorz Nosek [root at localdomain.pl] wrote:
| Hi,
| On sob, lip 18, 2009 at 01:52:44 -0700, Sukadev Bhattiprolu wrote:
| > 	virsh --connect lxc:/// start lxc-vm2
| > 
| > Is that what you mean by "just run" :-) ?
| > If so, I have to first resolve my unrelated problem with libvirtd+lxc.
| > 
| > Running "ns_exec -cpuim ./tty-bug", I dont get the failure with 2.6.31-rc3
| > on a Fedora 11 KVM.
| I get the oops by simply running the program, without libvirtd,
| lxc-tools or ns_exec (it sets up a mount namespace itself). Are you
| running with slub debugging (poisoning) enabled? 

I set 
	# CONFIG_SLUB_STATS is not set

and tried 2.6.29, 2.6.31-rc3 and linux-mmotm from July 13, but have
not been able to repro either on an i386 machine or on a KVM guest.

I run your program ./tty-bug in a tight loop. I will try to run the
program overnight in a loop. 

Given that your program does not depend on NET_NS, can you see if you
can repro on 2.6.28 and see if we can bisect this problem ?

| The bug causes
| access to freed memory, so otherwise often nothing will happen
| (the memory won't have been overwritten yet).
| OTOH, I haven't tried 2.6.31-rc3 either (but it doesn't look like fixed
| there too).
| Best regards,
|  Grzegorz Nosek

More information about the Containers mailing list