[PATCH 1/4] Support named cgroups hierarchies

Paul Menage menage at google.com
Tue Jul 28 16:17:51 PDT 2009

On Wed, Jul 22, 2009 at 11:50 PM, Li Zefan<lizf at cn.fujitsu.com> wrote:
>> Because it's not needed for the entire scope of the function. Keeping
>> its scope as small as possible makes it clearer what it's being used
>> for.
> If we had been doing this, we'll see many:
>        (no if, while, for)
>        {
>                ...
>        }
> in kernel code, but I don't remember I ever saw this style.

Documentation/CodingStyle is silent on this subject. But OK, I've
moved new_root back to the top level. I think that it's a net loss to
readability though.


More information about the Containers mailing list