Prefix / Naming USERCR API

Sukadev Bhattiprolu sukadev at linux.vnet.ibm.com
Fri Apr 9 20:48:40 PDT 2010


| > So, what would be a good prefix ?
| > 
| > 	cr_
| > 		cr_checkpoint.h, libcr.a
| > 		cr_checkpoint() cr_restart() cr_freeze() cr_migrate()
| > 		struct cr_checkpoint_args, struct cr_restart_args
| > 	acr_ 
| > 		Only advantage over 'cr_' is lesser likelihood of collision
| > 
| > 		acr_checkpoint.h, libacr.a
| > 		acr_checkpoint() acr_restart() acr_freeze() acr_migrate()
| > 		struct acr_checkpoint_args, struct acr_restart_args
| > 
| > 	lxcr_	
| > 		lxcr_checkpoint.h, liblxcr.a 
| > 		lxcr_checkpoint() lxcr_restart() lxcr_freeze() lxcr_migrate()
| > 		struct lxcr_checkpoint_args, struct lxcr_restart_args
| 
| I do not think lxcr_ prefix is a good choice as lxc is about container
| and could use different libraries for the checkpoint/restart function.

I was thinking of lx as short for linux, but ok. we can drop lxcr_.

Any NACKS to 'acr_' ? If not, I will go with it - for now :-)

Sukadev


More information about the Containers mailing list