[RFC][PATCH 0/6][usercr]: Rename/reorg usercr code

Sukadev Bhattiprolu sukadev at linux.vnet.ibm.com
Tue Apr 13 17:49:27 PDT 2010

Change the prefix of the USERCR apis to 'cr_' and reorg the code to avoid
duplication and reduce code size.

	[PATCH 1/6] Change API prefix to cr_
	[PATCH 2/6] Remove flags parameter to cr_checkpoint()
	[PATCH 3/6] Minor reorg of restart.c
	[PATCH 4/6] Move checkpoint() into restart.c
	[PATCH 5/6] Rename restart.c to cr_checkpoint.c
	[PATCH 6/6] Rename common.h to cr_log.h

With this change, USERCR for now "exports" just the following two files:


But this patchset does cause some churn, let me know if you think any of it
is unnecessary/noise.  I have tested for now along with the patch that removes
most exits() from cr_restart(). If the reorg makes sense, will run all tests
once more and resubmit.

	cr_checkpoint.c has several forward declarations - most of these can
  	be removed by reordering the code in the file. This would also
	reduce maintenance overhead when the prototype of the functions
	change. But changing it would cause more noise in the history.

More information about the Containers mailing list