[RFC][PATCH 0/6][usercr]: Rename/reorg usercr code

Oren Laadan orenl at cs.columbia.edu
Sun Apr 25 13:24:33 PDT 2010


Hi Suka,

Thanks for the patchset. A couple of comments:

* I prefer the header exported to users to be checkpoint.h - this
is consistent with kernel headers, and with future name of a c/r
library if we opt libcheckpoint.a

* I also prefer to leave checkpoint.c as a separate file, as is.
It may gain more functionality in the future. If the goal was to
only export a single .o file, then the solution IMHO is to instead
export a single library: libcheckpoint.a

Unless you have a strong opinion against the above, I'll go ahead
and pull patches 1-3, leave out 4-6, and update the Makefile to
create a libcheckpoint.a library.

Oren.


Sukadev Bhattiprolu wrote:
> Sukadev Bhattiprolu [sukadev at linux.vnet.ibm.com] wrote:
> | 
> | Change the prefix of the USERCR apis to 'cr_' and reorg the code to avoid
> | duplication and reduce code size.
> | 
> | 	[PATCH 1/6] Change API prefix to cr_
> | 	[PATCH 2/6] Remove flags parameter to cr_checkpoint()
> | 	[PATCH 3/6] Minor reorg of restart.c
> | 	[PATCH 4/6] Move checkpoint() into restart.c
> | 	[PATCH 5/6] Rename restart.c to cr_checkpoint.c
> | 	[PATCH 6/6] Rename common.h to cr_log.h
> | 
> | With this change, USERCR for now "exports" just the following two files:
> | 
> | 	cr_checkpoint.o
> | 	cr_checkpoint.h
> | 
> | But this patchset does cause some churn, let me know if you think any of it
> | is unnecessary/noise.  I have tested for now along with the patch that removes
> | most exits() from cr_restart(). If the reorg makes sense, will run all tests
> | once more and resubmit.
> 
> All tests in cr-tests pass with these two patchsets (on usercr ckpt-v20-dev
> and linux ckpt-v21-rc2).
> 
> Pls let me know if there are comments about the patchsets.
> 
> Thanks,
> 
> Sukadev
> 


More information about the Containers mailing list