[PATCH] user-c/r: get rid of ckpt_hdr_vpids - can be inferred at restart

Serge E. Hallyn serue at us.ibm.com
Tue Mar 30 12:39:36 PDT 2010


Quoting Oren Laadan (orenl at cs.columbia.edu):
> And some cleanup of recent nested-pids work, and re-generate
> user headers.
> 
> Signed-off-by: Oren Laadan <orenl at cs.columbia.edu>

...

> @@ -2721,26 +2716,28 @@ static int assign_vpids(struct ckpt_ctx *ctx)
> 
>  static int ckpt_read_vpids(struct ckpt_ctx *ctx)
>  {
> -	struct ckpt_hdr_vpids *h;
> -	int len, ret;
> +	int i, len, ret;
> 
> -	h = (struct ckpt_hdr_vpids *) ctx->vpids;
> -	ret = ckpt_read_obj_type(ctx, h, sizeof(*h), CKPT_HDR_VPIDS);
> -	if (ret < 0)
> -		return ret;
> +	for (i = 0; i < ctx->tasks_nr; i++)

s/tasks_nr/pids_nr/

With that applied,

Acked-by: Serge Hallyn <serue at us.ibm.com>
Tested-by: Serge Hallyn <serue at us.ibm.com>

Or:



More information about the Containers mailing list