[PATCH 1/6][lxc][v3] Add --with-libcr configure option

Michel Normand normand at fr.ibm.com
Wed Mar 31 01:11:30 PDT 2010


configure error because of typo below


Le mercredi 31 mars 2010 à 00:06 -0700, Sukadev Bhattiprolu a écrit :
> From: Sukadev Bhattiprolu <sukadev at linux.vnet.ibm.com>
> Date: Wed, 24 Mar 2010 17:26:44 -0700
> Subject: [PATCH 1/6][lxc][v3] Add --with-libcr configure option
> 
> Add a configure option, --with-libcr=dir which would allow linking
> with external (i.e USERCR) implementation  of checkpoint/restart.
> 
> For now, USERCR "publishes" a app-checkpoint.h, checkpoint.o and
> restart.o files which implement the functions app_checkpoint() and
> app_restart().
> 
> Usage:
> 	$ ./autogen.sh
> 
> 	$ ./configure --help |grep libcr
> 	--with-libcr=dir     use the Checkpoint/Restart implementation in 'dir'
> 
> 	$ ls /home/guest/user-cr/
> 	app-checkpoint.h    checkpoint.o    restart.o
> 
> 	$ ./configure --with-libcr=/home/guest/user-cr
> 
> TODO:
> 	If names of interfaces in USERCR change, we may want to rename
> 	the config option too ?
> 
> 	LIBCR_CFLAGS are only needed for src/lxc/{checkpoint.c,restart.c}
> 	but not sure if there is an easy way to define autoconf CFLAGS
> 	just for those two files.
> 
> Changelog[v2]:
> 	- Rename --with-usercr to --with-libcr
> 	- Add libeclone.a to the LIBCR_OBJS variable since functions in
> 	  libeclone.a will be used by checkpoint() and restart() functions.
> 	- Add -I${with_libcr}/include to LIBCR_CFLAGS to pick up
> 	  checkpoint_hdr.h, checkpoint.h etc.
> 
> Signed-off-by: Sukadev Bhattiprolu <sukadev at linux.vnet.ibm.com>
> ---
>  configure.ac        |   19 +++++++++++++++++++
>  src/lxc/Makefile.am |   10 +++++++++-
>  2 files changed, 28 insertions(+), 1 deletions(-)
> 
> diff --git a/configure.ac b/configure.ac
> index f82e7df..fe6584c 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -12,6 +12,25 @@ AM_PROG_CC_C_O
>  AC_GNU_SOURCE
>  AC_CHECK_PROG(SETCAP, setcap, yes, no, $PATH$PATH_SEPARATOR/sbin)
>  
> +AC_ARG_WITH(libcr, [AS_HELP_STRING([--with-libcr=dir], \
> +           [use the Checkpoint/Restart implementation in 'dir'])], [], \
> +	   [with_libcr=no])
> +
> +if test "x$with_libcr" != "xno"; then
> +       AS_AC_EXPAND(LIBCR_OBJS, "${with_libcr}/checkpoint.o ${with_libcr}/restart.o ${with_libcr}/libeclone.a")
> +       AS_AC_EXPAND(LIBCR_CFLAGS, "-DLIBCR -I${with_libcr} -I$(with_libcr}/include")

typo here $( to be replaced by ${

> +
> +       AC_CHECK_FILE([$with_libcr/app-checkpoint.h], [], \
> +               AC_MSG_ERROR([--with-libcr specified directory $with_libcr but $with_libcr/app-checkpoint.h was not found]))
> +
> +       AC_CHECK_FILE([${with_libcr}/checkpoint.o], [], \
> +               AC_MSG_ERROR([--with-libcr specified directory $with_libcr but ${with_libcr}/checkpoint.o was not found]))
> +
> +       AC_CHECK_FILE([${with_libcr}/restart.o], [], \
> +               AC_MSG_ERROR([--with-libcr specified directory $with_libcr but ${with_libcr}/restart.o was not found]))
> +fi
> +
> +
>  AC_ARG_ENABLE([doc],
>  	[AC_HELP_STRING([--enable-doc], [make mans (require docbook2man installed) [default=auto]])],
>  	[], [enable_doc=auto])
> diff --git a/src/lxc/Makefile.am b/src/lxc/Makefile.am
> index 890f706..699c355 100644
> --- a/src/lxc/Makefile.am
> +++ b/src/lxc/Makefile.am
> @@ -46,12 +46,20 @@ liblxc_so_SOURCES = \
>  	mainloop.c mainloop.h \
>  	af_unix.c af_unix.h
>  
> -AM_CFLAGS=-I$(top_srcdir)/src
> +# We only need $(LIBCR_CFLAGS) for lxc_checkpoint and lxc_restart files
> +# but for now, just set it for all.
> +AM_CFLAGS=-I$(top_srcdir)/src $(LIBCR_CFLAGS)
>  
>  liblxc_so_CFLAGS = -fPIC -DPIC $(AM_CFLAGS)
>  
> +# TODO: Adding $(LIBCR_OBJS) here ensures we don't have undefined references
> +# 	when building liblxc.so, but this has the side-effect of putting the
> +# 	app_checkpoint/restart functions in liblxc.so. Or alternatively,
> +# 	we could remove src/lxc/{checkpoint.o,restart.o} from liblxc.so
> +# 	and link lxc-checkpoint/lxc-restart with them directly.
>  liblxc_so_LDFLAGS = \
>  	-shared \
> +	$(LIBCR_OBJS) \
>  	-Wl,-soname,liblxc.so.$(firstword $(subst ., ,$(VERSION)))
>  
>  liblxc_so_LDADD = -lutil




More information about the Containers mailing list