Mounting blkio cgroup hierarchy

Ben Gamari bgamari at gmail.com
Fri Nov 12 09:13:24 PST 2010


I've been trying to configure cgroups and have encountered some very
strange behavior. In particular, when I follow the instructions in
Documentation/cgroups/blkio-controller.txt I quickly reach an error,

$ cd /mnt
$ sudo mkdir -p cgroups/blkio
$ # Confirm it's not already mounted:
$ cat /proc/mounts
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
none /dev devtmpfs rw,relatime,size=1993264k,nr_inodes=498316,mode=755 0 0
none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
/dev/disk/by-uuid/7d908a9f-fe46-4a82-bb2b-3fc108c96280 / ext4 rw,relatime,errors=remount-ro,barrier=1,data=ordered 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
/dev/sda1 /boot ext4 rw,relatime,barrier=1,data=ordered 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfs-fuse-daemon /home/ben/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
$ sudo mount -t cgroup -o blkio none /mnt/cgroups/blkio
mount: special device none does not exist

I've done quite a bit of Googling and yet it's very difficult to find
good information on configuring cgroups. I would use the libcg
toolset[1] but every attempt to configure it has ended in frustratingly
vague error messages.

Any ideas?

Cheers,

- Ben


More information about the Containers mailing list