2.6.35: unshare(NEWNS) does not work inside a container anymore?

Michael Tokarev mjt at tls.msk.ru
Wed Sep 1 12:53:58 PDT 2010

01.09.2010 23:41, Serge E. Hallyn wrote:
>>>> unshare(CLONE_NEWNS)              = -1 EINVAL (Invalid argument)
>>> 	 ns_exec -m /bin/bash;  play with mounts; exit)
>> This one is not using unshare(2), it is using clone(2) syscall.
> That's only the case if you do 'ns_exec -cm'.

Oh.  I missed that.
>> The source of this clone program is available at
>> http://www.corpit.ru/mjt/clone.c - I use it for
>> a long time, it works on this same machine
>> outside of containers, and it worked in 2.6.32.
> Hm, is working for me.  You're on a plain upstream 2.6.35, as in commitid
> 9fe6206f400646a2322096b56c59891d530e8d51 ?

No, it's - last stable.  Plain 2.6.35 works (or fails)
the same for me as 2.6.35 - this one:

But I see at least one possible difference: I run 64bit kernel
and a 32bit userspace, including lxc tools and unshare code.
Lemme check with 64bit (native) userspace....


More information about the Containers mailing list