[PATCH 1/9] cgroup: minor updates around cgroup_clear_directory()
lizefan at huawei.com
Thu Jul 11 06:42:34 UTC 2013
On 2013/6/29 7:45, Tejun Heo wrote:
> * Rename it to cgroup_clear_dir() and make it take the pointer to the
> target cgroup instead of the the dentry. This makes the function
> consistent with its counterpart - cgroup_populate_dir().
> * Move cgroup_clear_directory() invocation from cgroup_d_remove_dir()
> to cgroup_remount() so that the function doesn't have to determine
> the cgroup pointer back from the dentry. cgroup_d_remove_dir() now
> only deals with vfs, which is slightly cleaner.
> This patch doesn't introduce any functional differences.
> Signed-off-by: Tejun Heo <tj at kernel.org>
Acked-by: Li Zefan <lizefan at huawei.com>
More information about the Containers