[Fuego] Error while running a test on target connected to serial interface

dhinakar k dhinakar.k at gmail.com
Sun Jun 25 19:05:03 UTC 2017

Hi Tim,

Thanks for your inputs.
The issue seems to be because of improper upgrade to fuego 'next' branch.
I cleaned up everything and re-cloned and installed.
It works fine now. Sorry for the trouble and thanks a lot for your response.


On Fri, Jun 23, 2017 at 5:25 AM, Bird, Timothy <Tim.Bird at sony.com> wrote:

> > -----Original Message-----
> > From: dhinakar k [mailto:dhinakar.k at gmail.com]
> >
> > I have changed both Fuego and Fuego-core next branch.
> > When I tried serlogin inside container, I get the below error (the board
> has
> > been powered on and kept).
> > 'device reports readiness to read but returned no data (device
> disconnected)
> >
> > If I connect to the board via minicom and manually login, close the
> terminal
> > and the run a test e.g. hello_test it works fine.
> > So it seems serlogin is not able to login automatically to the connected
> board.
> Is this error occurring when serlogin is run in the context of Fuego, or
> have you tried it from the command line (inside the container or out)?
> Can you please get into minicom on the board serial port, then boot the
> board, and send the messages related to login?  The possibility I want
> to check is whether your login prompt is confusing serlogin.
> Do you require a password to log in?  What account are you using
> to log in?  What are the login prompt and the password prompt?
> serlogin is a new program, and I hoped it would not be this brittle,
> but apparently there are a lot of corner cases to handle.
> Thanks,
>  -- Tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfoundation.org/pipermail/fuego/attachments/20170626/ed99cf59/attachment-0001.html>

More information about the Fuego mailing list