[Fuego] unmet dependencies error when running ./install.sh
guicc at profusion.mobi
Mon Mar 19 16:02:56 UTC 2018
I agree with you. It seems not to be a very good idea to mix jessie
packages with unstable's.
I tried a few more things.
- Removing the security repo from apt sources.
Seems to solve the issue with the installation of the crosstoolchains, but
installation of other fuego dependencies:
*The following information may help to resolve the situation:*
> *The following packages have unmet dependencies:*
> * g++ : Depends: cpp (>= 4:4.9.2-2) but it is not going to be installed*
> * Depends: g++-4.9 (>= 4.6.4-1~) but it is not going to be installed*
> * Depends: gcc-4.9 (>= 4.6.4-1~) but it is not going to be installed*
> * gcc : Depends: cpp (>= 4:4.9.2-2) but it is not going to be installed*
> * Depends: gcc-4.9 (>= 4.9.2-1~) but it is not going to be installed*
> * gettext : Depends: libgomp1 (>= 4.9) but it is not going to be installed*
> * libtool : Depends: cpp but it is not going to be installed*
> * python-matplotlib : Depends: python-numpy (>= 1:1.8.0) but it is not
> going to be installed*
> * Depends: python-numpy-abi9**
> Recommends: python-glade2 but it is not going to be installed*
*- Moving to Debian Stretch (the new stable).Crosstoolchain packages
are already available on the stable strech repos.By changing our base image
to debian:stretch and replacing openjdk-7 with openjdk-8(version 7 is not
available on stretch) I was able to build successfully.I'm not sure if this
is a good solution, though. Moving from jessie to stretch wouldrepresent a
major change on Fuego, that could possibly break other things.*
Additionally, emdebian updates seem to have cease a while ago (last change
was in 2015), so
need to come up with alternatives for the sources of those toolchains.
Do you or anyone have any other suggestions?
On Sun, Mar 18, 2018 at 12:53 PM, Tuyển Hoàng <tuyen.hv.3i at gmail.com> wrote:
> Hello Guilherme,
> Thank you so much for your help!
> Actually, The ARM cross toolchain can be installed successfully with your
> but I do not think that adding debian unstable (sid) repository to the
> debian jessie
> system is a good idea.
> Normally, I think we should not add a different codename repository to a
> Debian system.
> This can make our system get issues related to unmet dependencies of
> version packages later.
> For example, When I add debian sid repository and install cross toolchain,
> It has 21 upgraded,
> 80 newly installed. For a long time, We can install or run packages from
> Debian Jessie and
> these packages can depend on packages with Jessie version but they updated
> version to Debian sid before.
> We can get problems with these packages.
> That is my opinion.
> How do you think about this?
> Thank you and Best regards,
> Fuego mailing list
> Fuego at lists.linuxfoundation.org
> 2018-03-18 20:21 GMT+07:00 Guilherme Camargo <guicc at profusion.mobi>:
>> Hello, Tuyen
>> I solved this issue by replacing the emdebian repository with
>> (sip). See the patch here
>> That patch has been applied on my fork, that's based on the branch
>> 'next', so it can't
>> be applied directly on master. I plan to send a patch to master this
>> Monday, but for now,
>> you may be able to fix that issue by doing the following:
>> -RUN echo "deb http://emdebian.org/tools/debian/ jessie main" >
>> -RUN dpkg --add-architecture armhf
>> -RUN curl http://emdebian.org/tools/debian/emdebian-toolchain-archive.key
>> | sudo apt-key add -
>> +RUN echo deb http://deb.debian.org/debian unstable main contrib
>> non-free >
>> + /etc/apt/sources.list.d/crosstools.list
>> +RUN dpkg --add-architecture armhf
>> Can you please try that out and tell me if it works for you?
>> On Sat, Mar 17, 2018 at 11:53 PM, Tuyển Hoàng <tuyen.hv.3i at gmail.com>
>>> Hello all,
>>> When I ran ./install, I got the below error:
>>> *Step 51 : RUN DEBIAN_FRONTEND=noninteractive apt-get update ---> Using
>>> cache ---> 0ee853280c49Step 52 : RUN DEBIAN_FRONTEND=noninteractive apt-get
>>> -yV install crossbuild-essential-armhf cpp-arm-linux-gnueabihf
>>> gcc-arm-linux-gnueabihf binutils-arm-linux-gnueabihf ---> Running in
>>> bec6bfd97f37Reading package lists...Building dependency tree...Reading
>>> state information...Some packages could not be installed. This may mean
>>> that you haverequested an impossible situation or if you are using the
>>> unstabledistribution that some required packages have not yet been
>>> createdor been moved out of Incoming.The following information may help to
>>> resolve the situation:The following packages have unmet
>>> dependencies: crossbuild-essential-armhf : Depends: g++-arm-linux-gnueabihf
>>> (>= 4.9.1-1) but it is not going to be installed gcc-arm-linux-gnueabihf :
>>> Depends: gcc-4.9-arm-linux-gnueabihf (>= 4.9.2-10) but it is not going to
>>> be installedE: Unable to correct problems, you have held broken
>>> packages.The command '/bin/sh -c DEBIAN_FRONTEND=noninteractive apt-get -yV
>>> install crossbuild-essential-armhf cpp-arm-linux-gnueabihf
>>> gcc-arm-linux-gnueabihf binutils-arm-linux-gnueabihf' returned a non-zero
>>> code: 100*
>>> How to reproduce the issue?
>>> I cleaned all the old Jessie docker images and containers on my machine
>>> then run ./install.sh.
>>> This will re-clone a new Jessie docker image.
>>> I think this issue also occurs if we setup Fuego on a new machine.
>>> After several checks about the dependence of packages, I see that
>>> gcc-4.9-arm-linux-gnueabihf package depends on: libgcc-4.9-dev:armhf (=
>>> 4.9.2-10) but 4.9.2-10+deb8u1 is to be installed
>>> The reason that some packages in emdebian.org
>>> <http://emdebian.org/tools/debian/dists/jessie/main/> repository are
>>> older than the current Jessie docker image and security.debian.org
>>> How should we do to solve the issue?
>>> Best regards,
>>> Fuego mailing list
>>> Fuego at lists.linuxfoundation.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Fuego