[Fuego] Test not getting updated in pptlab

Tim.Bird at sony.com Tim.Bird at sony.com
Thu Jan 28 18:55:16 UTC 2021


Pooja,

I'm still having problems updating tests in the PathPartner lab.
I think there is some kind of filesystem or permission problem with /fuego-rw/tests.

Some tests appear to work fine, but a few others are still having problems, when
I run them remotely:
 - Functional.reboot
 - Functional.fuego_lab_check

I'd like to actually run through a few tests during our conference call, so we can
examine poll_requests.sh/ftc output and try to see what the issues are with these tests.

Thanks,
 -- Tim




> -----Original Message-----
> From: Pooja Sanjay More <pooja.sm at pathpartnertech.com>
> 
> Hi Tim,
> 
> poll_request.sh was running with -u option only.
> Few tests that you put executed successfully.
> One test failed because of permission.
> I have changed the ownership of /fuego-rw/buildzone from
> root to jenkins.
> 
> We have kept ttc.conf under /fuego-ro/conf/ folder inside old container
> just to get Functional.reboot working first then will move the same
>  to a more generic folder /usr/test inside the new container(built already
> with /usr/test volume mounted, need to configure for jenkins job).
> I did a git pull and tried the Functional.reboot test multiple times,
> it's working fine.
> 
> Logs for the same :
> 
> Running as SYSTEM
> Building on master in workspace /var/lib/jenkins/jobs/poll_requests_on_server/workspace
> [workspace] $ /bin/sh -xe /tmp/jenkins6221678271780851761.sh
> + /fuego-core/scripts/poll_requests.sh -u -d 12h -w 120
> == Polling server "fuegotest.org/cgi-bin <http://fuegotest.org/cgi-bin> " for requests ==
> Processing requests for any board
> Installing new tests or upgrading tests is allowed.
> Waiting 120 seconds between polls of the server.
> Running for 12h
> Type Ctrl-C to exit
> Checking
> Running request: request-2021-01-22_06:42:55.57-pptlab:rpi
> Trying to get request 'request-2021-01-22_06:42:55.57-pptlab:rpi' from server
> Checking for (possibly newer) test Functional.reboot on server.
> Executing test Functional.reboot on board rpi (using spec default)
> Running test 'Functional.reboot' on board 'rpi' using spec 'default'
> ===== doing fuego phase: pre_test =====
> ===== doing fuego phase: build =====
> The test is already built
> Fuego test_build duration=0 seconds
> ===== doing fuego phase: deploy =====
> ===== doing fuego phase: snapshot =====
> Firmware revision: 5.4.83-v7-77+
> ===== doing fuego phase: run =====
> -------------------------------------------------
> TAP version 13
> 1..3
> Calling target_reboot for board rpi...
> Connection to 192.168.3.123 closed by remote host.
> # uptime of board=37 (seconds)
> # duration of reboot=44 (seconds)
> ok 1 - software reboot with target_reboot
> # BOARD_CONTROL=ttc
> ok 2 - board has BOARD_CONTROL setting
> Calling ov_board_control_reboot for board rpi...
> comunicating with relay board
> 
> Serial<id=0x7f6d516eb210, open=True>(port='/dev/ttyUSB0', baudrate=9600, bytesize=8, parity='N', stopbits=1, timeout=3.0,
> xonxoff=False, rtscts=False, dsrdtr=False)
> Checking for ping..
> 
> ('Data read is :', 'R')
> 
> 
> <function ping at 0x7f6d517012a8>
> Sleeping for 3 secs
> 
> Resetting the RPI board
> 
> RELAY1_OFF_COMMAND: 0x31
> 
> usb device turned OFF successfully
> 
> Sleeping for 2 secs
> 
> RELAY1_ON_COMMAND: 0x51
> 
> usb device turned ON successfully
> 
> Closing Serial Port
> # uptime of board=56 (seconds)
> # duration of reboot=67 (seconds)
> ok 3 - hardware reboot with ov_board_control_reboot
> -------------------------------------------------
> ===== doing fuego phase: post_test =====
> scp: /home/pi/test/fuego.Functional.reboot/Functional.reboot.log: No such file or directory
> INFO: the test did not produce a test log on the target
> run/
> run/run.json
> scp: /tmp/fuego.Functional.reboot/rpi.10.10.before: No such file or directory
> Warning: no matching Jenkins job found. Not populating Jenkins build directory
> Packaging run 'Functional.reboot-default-10-rpi'
> Run packaged successfully, and is at: /tmp/run-Functional.reboot-default-10-on-pptlab:rpi.frp
> Run package run-Functional.reboot-default-10-on-pptlab:rpi.frp was accepted by the server.
> Run Functional.reboot-default-10-rpi put to server
> 
> 
> Please put requests now.
> 
> 
> Thanks and regards,
> Pooja More
> 
> 
> 
> On Fri, Jan 22, 2021 at 6:08 AM <Tim.Bird at sony.com <mailto:Tim.Bird at sony.com> > wrote:
> 
> 
> 	Pooja,
> 
> 	Can you please double-check that the poll_request.sh script is getting run with the '-u' option?
> 	I have tried updating the Functional.fuego_lab_check test (by putting a new one on fuegotest.org <http://fuegotest.org> )
> 	and running an updated one, and trying to force an upgrade in your lab by submitting a request
> 	with version="latest".  However, the request ends up running an old broken version of
> 	Functional.fuego_lab_check.  So something is going wrong.
> 
> 	Can you also please do a 'git pull' of fuego-core?  That will at least upgrade the 'fuego_lab_check'
> 	test to the current version (which has some important fixes).  Once that test can be upgraded
> 	remotely, it will give me data I can use to diagnose problems in your lab remotely (like
> 	check directory permissions inside the container)
> 
> 	Thanks,
> 	 -- Tim
> 
> 
> 
> 
> This message contains confidential information and is intended only for the individual(s) named. If you are not the intended recipient, you
> are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this mail and attached file/s is strictly
> prohibited. Please notify the sender immediately and delete this e-mail from your system. E-mail transmission cannot be guaranteed to be
> secured or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. The
> sender therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail
> transmission.



More information about the Fuego mailing list