[Lightning-dev] Pay-to-Open and UX improvements

ZmnSCPxj ZmnSCPxj at protonmail.com
Thu Dec 19 06:24:15 UTC 2019


Good morning t-bast,

> > -   A script-path spend with the following script (and only that script):
> >     OP_SWAP OP_DUP <R> OP_EQUALVERIFY OP_SWAP <P> OP_CHECKSIG
> >
>
> Why not this:
>
> <R> OP_SWAP OP_CHECKSPLITSIG
>
> ?
>
> Since `R` is constrained to be fixed anyway, why repeat `R` twice, once in the script and once in the witness stack?

For that matter, since we are far more likely to have a constant `R` than a constant `s` maybe you should instead propose that `OP_CHECKSPLITSIG` be given `<s> <R> <P> OP_CHECKSPLITSIG`, so that a fixed-`R` single-show signature is just `<R> <P> OP_CHECKSPLITSIG`.

Regards,
ZmnSCPxj


More information about the Lightning-dev mailing list