[Linux-kernel-mentees] [PATCH v4 0/3] lspci: Update verbose help and show_range()

Kelsey Skunberg skunberg.kelsey at gmail.com
Wed Jun 19 16:48:55 UTC 2019


Changes since v1:
  - Expand changes into more patches for easier review.
  - Combine three patches for lspci.c into patchset.

  * Patch 1: lspci: Include -vvv option in help
    No changes made. Added to series for review.

  * Patch 2: lspci: Remove unnecessary !verbose check in show_range()
    Move into it's own patch since v1. Dead code which checks for
    verbosity to be true.

  * Patch 3: lspci: Replace output for bridge with empty range from
    "None" to "[empty]"
    Patch builds off Patch 2 to change show_range() output to be more
    consistent between each level of verbosity.

Changes since v2:
  * Patch 1: Update commit log to imperative mood

  * Patch 2: Fix logical error
        Previous:
        (base > limit || verbose < 3)
        New:
        (base > limit && verbose < 3)

  * Patch 3: Fix logical error
        Previous:
        base > limit
        New:
        base <= limit

Changes since v3:
  * Patch 1 and 2: No change
  * Patch 3: Change output from "[empty]" to "[disabled]"

Kelsey Skunberg (3):
  lspci: Include -vvv option in help
  lspci: Remove unnecessary !verbose check in show_range()
  lspci: Change output for bridge with empty range to "[disabled]"

 lspci.c | 24 ++++++++----------------
 1 file changed, 8 insertions(+), 16 deletions(-)

--
2.20.1



More information about the Linux-kernel-mentees mailing list