[Linux-kernel-mentees] [PATCH v2] lib: kunit: Convert test_sort to KUnit test

Andy Shevchenko andriy.shevchenko at linux.intel.com
Mon Aug 3 08:57:21 UTC 2020

On Wed, Jul 29, 2020 at 12:59:28PM -0700, Brendan Higgins wrote:
> On Wed, Jul 29, 2020 at 12:19 PM Andy Shevchenko
> <andriy.shevchenko at linux.intel.com> wrote:
> > On Wed, Jul 29, 2020 at 04:11:51PM -0300, Vitor Massaru Iha wrote:


> > >  lib/{test_sort.c => sort_kunit.c} | 31 +++++++++++++++----------------
> >
> > Still opened question why kunit is a suffix? Can't we leave same name? Can't we
> > do it rather prefix?
> Sorry to jump in now; I thought Vitor's reply with a link to the new
> proposed documentation[1] addressed this. The naming convention issue
> came up about a month ago[2]. The people in the discussion (including
> myself) came to an agreement on _kunit.c. That being said, the
> documentation hasn't been accepted yet, so if you really feel strongly
> about it, now is the time to change it.

My argument is to do something like

  - ls .../test* vs. ls .../*_kunit.c

  - use shell completion vs. no completion when looking if there is a test
    module for something

But I agree that this is matter of style.

> All that being said, I would rather not discuss that issue here for
> the benefit of the participants in the preceding discussions.
> I posted lore links for the relevant threads, which should be easy
> enough to In-Reply-To your way into. Nevertheless, if it makes it
> easier, let me know and I can CC you into the discussions.

No need. I think you have enough clever folks and good ideas behind this. Just
put a reference to all these conversion patches to the summary of pros and cons
of renaming.

> [1] https://lore.kernel.org/linux-kselftest/20200620054944.167330-1-davidgow@google.com/T/#u
> [2] https://lore.kernel.org/linux-kselftest/202006141005.BA19A9D3@keescook/t/#u

With Best Regards,
Andy Shevchenko

More information about the Linux-kernel-mentees mailing list