[Linux-kernel-mentees] [kbuild-all] Re: [PATCH v1 1/4] ide: use generic power management

Xia, Hui hui.xia at intel.com
Mon Jun 29 13:53:49 UTC 2020

>-----Original Message-----
>From: Bjorn Helgaas <helgaas at kernel.org>
>Sent: 2020年6月26日 23:35
>To: lkp <lkp at intel.com>
>Cc: Vaibhav Gupta <vaibhavgupta40 at gmail.com>; bjorn at helgaas.com; Vaibhav
>Gupta <vaibhav.varodek at gmail.com>; David S. Miller <davem at davemloft.net>;
>kbuild-all at lists.01.org; netdev at vger.kernel.org; linux-kernel at vger.kernel.org;
>linux-kernel-mentees at lists.linuxfoundation.org; skhan at linuxfoundation.org;
>linux-ide at vger.kernel.org
>Subject: [kbuild-all] Re: [PATCH v1 1/4] ide: use generic power management
>On Thu, Jun 25, 2020 at 06:14:09AM +0800, kernel test robot wrote:
>> Hi Vaibhav,
>> Thank you for the patch! Yet something to improve:
>> [auto build test ERROR on ide/master]
>> [If your patch is applied to the wrong git tree, kindly drop us a note.
>> And when submitting patch, we suggest to use  as documented in
>> https://git-scm.com/docs/git-format-patch]
>> url:    https://github.com/0day-ci/linux/commits/Vaibhav-Gupta/drivers-ide-
>> base:   https://git.kernel.org/pub/scm/linux/kernel/git/davem/ide.git master
>> config: x86_64-randconfig-a004-20200624 (attached as .config)
>This auto build testing is a great service, but is there any way to tweak the info
>above to make it easier to reproduce the problem?
>I tried to checkout the source that caused these errors, but failed.
>This is probably because I'm not a git expert, but maybe others are in the same
>boat.  For example, I tried:
>  $ git remote add kbuild https://github.com/0day-ci/linux/commits/Vaibhav-
>  $ git fetch kbuild
>  fatal: repository 'https://github.com/0day-ci/linux/commits/Vaibhav-
>Gupta/drivers-ide-use-generic-power-management/20200625-013242/' not
>I also visited the github URL in a browser, and I'm sure there must be information
>there that would let me fetch the source, but I don't know enough about github
>to find it.
>The report doesn't include a SHA1, so even if I *did* manage to fetch the sources,
>I wouldn't be able to validate they were the *correct* ones.
Hi Bjorn,

Please try:
$ git remote add kbuild https://github.com/0day-ci/linux.git
$ git fetch kbuild
$ git checkout 1835cfb6a85a52c4c7459e163d2c850e8b71ce9f

The commit sha1 1835cfb6a85a52c4c7459e163d2c850e8b71ce9f could be found in web page at https://github.com/0day-ci/linux/commits/Vaibhav-Gupta/drivers-ide-use-generic-power-management/20200625-013242
We will enhance the report information to make it easier to fetch the source code. Thanks for reporting.

>> compiler: gcc-9 (Debian 9.3.0-13) 9.3.0 reproduce (this is a W=1
>> build):
>>         # save the attached .config to linux build tree
>>         make W=1 ARCH=x86_64
>> If you fix the issue, kindly add following tag as appropriate
>> Reported-by: kernel test robot <lkp at intel.com>
>> All errors (new ones prefixed by >>, old ones prefixed by <<):
>> >> ERROR: modpost: "ide_pci_pm_ops" [drivers/ide/ide-pci-generic.ko]
>> >> ERROR: modpost: "ide_pci_pm_ops" [drivers/ide/serverworks.ko] undefined!
>> >> ERROR: modpost: "ide_pci_pm_ops" [drivers/ide/piix.ko] undefined!
>> >> ERROR: modpost: "ide_pci_pm_ops" [drivers/ide/pdc202xx_old.ko]
>> >> ERROR: modpost: "ide_pci_pm_ops" [drivers/ide/ns87415.ko] undefined!
>> >> ERROR: modpost: "ide_pci_pm_ops" [drivers/ide/hpt366.ko] undefined!
>> ---
>> 0-DAY CI Kernel Test Service, Intel Corporation
>> https://lists.01.org/hyperkitty/list/kbuild-all@lists.01.org
>kbuild-all mailing list -- kbuild-all at lists.01.org To unsubscribe send an email to
>kbuild-all-leave at lists.01.org

More information about the Linux-kernel-mentees mailing list