[llvmlinux] Raspberry Pi USB driver problem

Tinti viniciustinti at gmail.com
Wed Dec 19 16:17:41 UTC 2012


I think I have found the problem, but I don't know how to solve it.

Raspberry Pi uses a SMSC95XX chip which is an USB hub and Ethernet device.
This module is compiled statically in kernel. So, I have tried to built it
as a module and see if I get any difference between GCC and Clang builds.

It has indeed, and I really believe that it the root cause. The clang build
does not have the "init.text" section. Neither some others that Gcc version

I have tried with usbmon.ko and smsc95xx.ko. Clang produces "init.text" for
usbmon but not for smsc95xx.ko.

To reproduce just set SMSC95XX=m and use the -fno-vectorize flag to build
Raspberry Pi in my branch.


Vinicius Tinti
mail => {viniciustinti at gmail.com, tinti at comp.eng.br}
skype => {viniciustinti}
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfoundation.org/pipermail/llvmlinux/attachments/20121219/5ce5508f/attachment.html>

More information about the LLVMLinux mailing list