[llvmlinux] A few changes for ubu-13.04/64: Add flex and other pkgs.

Behan Webster behanw at converseincode.com
Fri May 3 23:53:42 UTC 2013

On 13-05-03 05:46 PM, Randy MacLeod wrote:
> I tired tog et registered on the llvm wiki but that seems to take a while.
Drat. I'm still not getting emails when new people request access.

Sorry about that. You're now registered. Thanks for your patience.

> tinti on IRC volunteered to do the editing so here's the email summary.
Tinti should have just kicked me (or Jan-Simon) instead. :P

> // Randy
> ---
> I'm building llvmlinux on a fairly fresh install of ubuntu 13.04/64bit 
> and noticed that the list of packages to apt-get was not complete. The 
> build system does catch each omission but
> I think it would be better for newbies if  the apt-get/yum list 
> included all the packages
> to make vexpress and x86_64 and that we document
> . There are a number of other pacakges that I had to
> add but perhaps they are target specific. Anyway, if you want a list, 
> I had to add these:
>   - flex libfdt1 libfdt-dev  libpixman-1-dev libpixman-1-0
Hmm. The auto dependency checking should have complained about those.

Added to the wiki in any case.

> Could you at least add flex to the list here:
> http://llvm.linuxfoundation.org/index.php/Quick_Start_Guide
> A few notes below if you want to know some of the context in which I 
> found I had to add packages.
> On to building oe-core native pkgs using clang and perhaps working 
> with Khem to add llvm and clang to oe-core.
> // Randy
> BTW, my first build of x86_64 failed (no logs, oops) so then I built 
> vexpress and that worked although I did have to add the package 
> libfdt1. The build system was kind enough to fail and ask for that pkg.
Oh good. That's the way it's supposed to work.

> Then, iirc, I was building target/x86_64 and found:
> Finished state qemu-patch
> ---------------------------------------------------------------------
> dpkg-query: no packages found matching sparse
> dpkg-query: no packages found matching libfdt-dev
> ---------------------------------------------------------------------
> Checking build dependencies
> ---------------------------------------------------------------------
> All build dependencies were found
Hmm. That doesn't seem right. Will investigate.

> ---------------------------------------------------------------------
> Configure QEMU...
> ---------------------------------------------------------------------
> (cd /home/rmacleod/src/lang/llvm/llvmlinux.git/test/qemu/build/qemu && 
> /home/rmacleod/src/lang/llvm/llvmlinux.git/test/qemu/src/qemu/configure \
> --target-list=arm-softmmu,mips-softmmu,i386-softmmu,x86_64-softmmu 
> --disable-kvm --disable-vnc \
> --disable-sdl --audio-drv-list="" --audio-card-list="" --enable-fdt \
> --disable-docs 
> --prefix=/home/rmacleod/src/lang/llvm/llvmlinux.git/test/qemu/install)
> ERROR: pixman not present. Your options:
>          (1) Preferred: Install the pixman devel package (any recent
>              distro should have packages as Xorg needs pixman too).
>          (2) Fetch the pixman submodule, using:
>              git submodule update --init pixman
> so I added:
>   libpixman-1-dev libpixman-1-0
> and then later: libfdt-dev for some reason.
Those all should have been complained about by the dependency system. 
Appologies. They're in the list to check for, but obviously there is a 
bug. Will investigate.

Thanks Randy!


Behan Webster
behanw at converseincode.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfoundation.org/pipermail/llvmlinux/attachments/20130503/5b75dc01/attachment-0001.html>

More information about the LLVMLinux mailing list