[lsb-discuss] problem about installing appbat

Wichmann, Mats D mats.d.wichmann at intel.com
Thu Aug 3 06:11:24 PDT 2006

>I am now install lsb-apache-2.2.0-2.lsb3.i486.rpm on ubuntu as this:
>first,i run :
>rpm -ivh lsb-apache-2.2.0-2.lsb3.i486.rpm
>but the result is:
>warning: lsb-apache-2.2.0-2.lsb3.i486.rpm: Header V3 DSA 
>signature: NOKEY, key ID 3b1dccac
>error: Failed dependencies:
>        lsb >= 3.1 is needed by lsb-apache-2.2.0-2.lsb3.i486
>        /bin/sh is needed by lsb-apache-2.2.0-2.lsb3.i486

yeah, this part isn't going to work, you can't use rpm to
install packages on a debian/ubuntu system. well, you *can*
if you create the database first (which you seem to have
done) but all the dependencies will be wrong and probably
so will lots of other things.

>then i run:
>alien -c lsb-apache-2.2.0-2.lsb3.i486.rpm
>the result is:
>lsb-apache_2.2.0-3_i386.deb generated
>and i run the command:dpkg -i lsb-apache_2.2.0-3_i386.deb
>the result is:
>(Reading database ... 75949 files and directories currently installed.)
>Preparing to replace lsb-apache 2.2.0-3 (using 
>lsb-apache_2.2.0-3_i386.deb) ...
>Unpacking replacement lsb-apache ...
>Setting up lsb-apache (2.2.0-3) ...

this is better, but I suggest you start from a clean
state since it seems to have thought lsb-apache was
at least partially installed already ("preparing to
replace...").  Start with:
dpkg --purge lsb-apache

and then try the installation of the converted 
lsb_apache deb again.

More information about the lsb-discuss mailing list