[lsb-discuss] Inconsistency between glibc and POSIX fixed

Nick Stoughton nick at msbit.com
Wed Jun 21 10:03:47 PDT 2006


On Wed, 2006-06-21 at 09:52 -0700, Wichmann, Mats D wrote:
> This is great news!
> 
> We still need to document this, however; it will be two years (LSB 4.0) before we can
> require LSB conforming distributions to run the version of glibc that fixes will
> appear in (unless he also backported to the 2.3 series).
On the other hand, this is a clear, simple, bug-fix, supported by the
upstream maintainer. I would be surprised if distro-vendors were unable
to patch their current glibc to handle this. I'd like to see this going
into 3.2 ... I don't want to preserve differences to POSIX artificially.
Its also fairly clear that few apps have been affected by this ... it
took a test suite to find it, and not an ISV asking why her app core
dumped. 
-- 
Nick 





More information about the lsb-discuss mailing list