[lsb-discuss] Moving Qt4 to required for LSB 3.2

Alan Cox alan at lxorguk.ukuu.org.uk
Mon Apr 23 03:09:44 PDT 2007


On Mon, 23 Apr 2007 11:49:06 +0200
Olaf Schmidt <ojschmidt at kde.org> wrote:

> [ Alan Cox, Fr., 20. Apr. 2007 ]
> > I would concur that this is several years too early in the big scheme of
> > things to make QT4 mandatory.
> 
> Several years?

Distributions lacking QT4 will be shipping and in regular use for several
more years before they begin to tail off and go out of production. That
means in practical terms application vendors won't be able to require Qt4
for some time.

> We already released the Qt4 module as a "future candidate" alongside LSB 3.1. 
> We had reached consensus that Qt4 will become mandatory once it is shipped by 
> the current generation of distributions.

Sorry - I wasn't trying to disagree with this. What vendors ship to and
what new LSB versiosn require are clearly not the same thing, or we'd
never get anywhere.

Alan




More information about the lsb-discuss mailing list