[lsb-discuss] Getting started with LSB Sample Implementation environment

Daniel Yek dyek at real.com
Fri Mar 2 13:07:24 PST 2007


So, helloworld didn't execute because of wrong dynamic linker specified in 
the header. With a symbolic link created, I'm able to run helloworld now. I 
was just about at this point the last time I tackle SI.

bash-3.1$ ./lsbappchk helloworld
Checking binary helloworld
Incorrect program interpreter: /lib/ld-linux.so.2
Header[ 1] PT_INTERP       Failed
Found wrong intepreter in .interp section: /lib/ld-linux.so.2 instead of: 
/lib/ld-lsb.so.3


bash-3.1$ ls -l /lib/ld-linux.so.2
lrwxrwxrwx 1 root root 14 Mar  2 12:55 /lib/ld-linux.so.2 -> /lib/ld-2.4.so

bash-3.1$ ./helloworld
Hello World!


So, my immediate question is what I need to do so that LSB BE will get the 
dynamic linker correct?

My BE is probably more than 4 month old. I wonder if there is any changes 
in LSB packages such that if I were to set up a new BE, problems would 
disappear.


-- 
Daniel Yek


At 12:30 PM 3/2/2007, Daniel Yek wrote:
>OK, I finished setting up a new LSB SI on i386 Ubuntu Edgy as follow:
>
>wget
>http://ftp.freestandards.org/pub/lsb/impl/released-3.1.0/binary/ia32/lsbsi-core-ia32-3.1.1.tar.bz2
>
>sudo -i
>bunzip2 --keep lsbsi-core-ia32-3.1.1.tar.bz2
>cd /opt
>tar xvf /home/dyek/temp/lsbsi-core-ia32-3.1.1.tar
>
>sudo /usr/sbin/chroot /opt/lsbsi-core-ia32
>
>/usr/sbin/useradd -s /bin/sh dyek
>chown dyek:dyek /opt/lsbsi-core-ia32/home/dyek
>cp helloworld /opt/lsbsi-core-ia32/home/dyek/
>
>bash-3.1# su dyek
>sh-3.1$ cd
>sh-3.1$ pwd
>/home/dyek
>
>  From outside SI, copy helloworld built from LSB BE into SI.
>
>sh-3.1$ ./helloworld
>sh: ./helloworld: No such file or directory
>
>Can core package alone support execution of helloworld?
>
>Thanks.
>
>
>--
>Daniel Yek
>
>
>At 11:33 AM 3/2/2007, Daniel Yek wrote:
> >Hi,
> >
> >I didn't manage to get LSB Sample Implementation working the last time I
> >tried it. I'm attacking the problem again and I really need support from
> >LSB SI expert if I ever have a chance of getting it working.
> >
> >So, I built a C HelloWord program in the LSB Build Environment:
> >
> >bash-3.1$ gcc -o helloworld helloworld.c
> >
> >I then copied helloworld into the SI environment and attempt to execute it:
> >bash-3.1$ ./helloworld
> >bash: ./helloworld: No such file or directory
> >
> >I couldn't.
> >
> >I tried a lot of workaround the last time around and was only barely
> >making ever slight progress.
> >
> >I originally did the same thing on a i386 machine and got the same result.
> >Now, that hard drive is mounted on a x86_64 machine and I think there are
> >potentially more incompatibilities. So, I'm going to set up a new LSB SI
> >on a i386 machine and get back to the mailing list later.
> >
> >I need someone to point out to me how SI can be utilized successfully and
> >what mistake I made. More info. later as I set up a new SI environment.
> >
> >Thanks.
> >
> >--
> >Daniel Yek




More information about the lsb-discuss mailing list