[lsb-discuss] Getting started with LSB

Bruce Dubbs bruce.dubbs at gmail.com
Mon Apr 21 23:21:09 PDT 2008

If this is the wrong list, please point me to the proper place to address my 

After attending the LSB meeting at the Linux Collaboration Summit two weeks ago, 
I decided to try to make Linux From Scratch LSB compliant.

I downloaded the LSB 3.2 Distribution Testkit (IA32) and installed it, but I 
can't get it to run any tests.  The error I get is:

/test_suites/released-3.2/binary/runtime/lsb-tet3-lite-3.7-11.lsb3.i486.rpm was 
not correctly installed.

When I tried to install this rpm manually, I got:

error: Failed dependencies:
         lsb-core-ia32 >= 3.0 is needed by lsb-tet3-lite-3.7-11.lsb3.i486
         /bin/sh is needed by lsb-tet3-lite-3.7-11.lsb3.i486

1.  Where do I get lsb-core-ia32 ?
2.  Why do I get /bin/sh is needed... ?  I tried it with a symlink to bash and I 
copied the full bash binary to /bin/sh and got the same error.

My system is *not* RPM based (it is built form source) so the 2nd point may be 
something to do with not having /bin/sh in the rpm database.

Thanks for any help you can give.

   -- Bruce Dubbs

More information about the lsb-discuss mailing list