[lsb-discuss] Getting started with LSB

Jeff Licquia jeff at licquia.org
Tue Apr 22 06:31:42 PDT 2008

Bruce Dubbs wrote:
> After attending the LSB meeting at the Linux Collaboration Summit two weeks ago, 
> I decided to try to make Linux From Scratch LSB compliant.


> I downloaded the LSB 3.2 Distribution Testkit (IA32) and installed it, but I 
> can't get it to run any tests.  The error I get is:
> Package 
> /test_suites/released-3.2/binary/runtime/lsb-tet3-lite-3.7-11.lsb3.i486.rpm was 
> not correctly installed.
> When I tried to install this rpm manually, I got:
> error: Failed dependencies:
>          lsb-core-ia32 >= 3.0 is needed by lsb-tet3-lite-3.7-11.lsb3.i486
>          /bin/sh is needed by lsb-tet3-lite-3.7-11.lsb3.i486
> 1.  Where do I get lsb-core-ia32 ?

That is a package the distribution provides.  It's supposed to be a 
guarantee that the LSB components are, in fact, installed.

What that guarantee means is up to the distribution.  Debian, for 
example, provides a "lsb" Debian package, which can be installed with 
its package management tools.

If I understand what you're doing, you seem to be just using rpm to 
provide LSB package installation.  In that case, as long as your 
distribution ensured that the LSB components were installed, you could 
install a dummy package that provided lsb-core-* and the other requirements.

> 2.  Why do I get /bin/sh is needed... ?  I tried it with a symlink to bash and I 
> copied the full bash binary to /bin/sh and got the same error.
> My system is *not* RPM based (it is built form source) so the 2nd point may be 
> something to do with not having /bin/sh in the rpm database.

That's very likely.  However, it also looks like a bug in our package; 
we should not include such a dependency in our packages.

I've filed bug 2060 for this problem:


More information about the lsb-discuss mailing list