[lsb-discuss] Build error from lsb-test-printing-3.2.0-1.src.rpm

Hao Liu hliu at redhat.com
Mon Aug 25 22:53:52 PDT 2008

Hi, guys,
  Running lsb-test-printing test on my machine gives out 2 errors:

    /testfoomaticrip/testfoomaticrip 3 FAIL
    /testfoomaticrip/testfoomaticrip 11 FAIL

I tried to analyse the source of lsb-test-printing to find out what's 
going wrong here,
as root,

      rpm  -i lsb-test-printing-3.2.0-1.src.rpm
      cd /usr/src/redhat/SPECS
      rpmbuild -bc lsb-test-printing.spec

it gives out error msg:

    error: File /usr/src/redhat/SOURCES/lsb-test-printing-%{ver}.tar.gz:
    No such file or directory
    Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.e4CTpk
    + umask 022
    + cd /usr/src/redhat/BUILD
    + LANG=C
    + export LANG
    + unset DISPLAY
    + cd /usr/src/redhat/BUILD
    + rm -rf printing-test
    + exit 0
    Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.5tlQWj
    + umask 022
    + cd /usr/src/redhat/BUILD
    + cd printing-test
    /var/tmp/rpm-tmp.5tlQWj: line 24: cd: printing-test: No such file or
    error: Bad exit status from /var/tmp/rpm-tmp.5tlQWj (%build)

Look at the red lines, it first remove the dir, then it tried to enter 
the dir, I'm really confused, would someone like to enlight me?

Thank you.

All the best,
Hao Liu

More information about the lsb-discuss mailing list