[lsb-discuss] Infrastructure upgrade: bzr repositories will soonneed newer bzr

Wichmann, Mats D mats.d.wichmann at intel.com
Thu Feb 21 13:51:25 PST 2008


lsb-discuss-bounces at lists.linux-foundation.org wrote:
> I'm getting ready to upgrade the bzr repositories for the devel
> branches.  Those who were involved with the 3.2 release will remember
> some of the bzr-related issues we had to deal with.  Two of
> these--speed and weird behavior with the tags plugin--require a
> repository format upgrade to fix. 
> 
> If you have bzr 0.92 or greater, you should not be affected.  People
> using bzr versions earlier than that will lose the ability to
> work with
> the LSB repositories on bzr.linux-foundation.org.
> 
> Upgrading should be fairly easy.  The Bazaar project provides packages
> for some distributions; it's at bazaar-vcs.org.  Mats has also created
> LSB-compliant packages of bzr (when coupled with the lsb-python
> appbat package) at his LF page: 
> 
> http://www.linux-foundation.org/~mats/
> 
> Or, of course, you can grab the source and build it yourself.

Even if not packaged explicitly for your distribution, a 1.0
or greater version is recommended!




More information about the lsb-discuss mailing list