[lsb-discuss] What version of glibc to target?

Wichmann, Mats D mats.d.wichmann at intel.com
Tue Feb 26 09:14:15 PST 2008


> With respect to the interfaces in glibc 2.5 that are not in glibc 2.4,
> but which might meet the criteron on, "would not prevent SLES10,
> RHEL5, and Ubuntu Hardy from certifying", I believe we should not want
> to add the interface unless there were specific, significant ISV
> applications that would require it --- simply from a simplicity point
> of view, especially with respect to the Sample Implementation.


I haven't heard any of the interfaces /past/ glibc 2.4 be requested 
at all; in fact the only interface set "verbally" requested is
the inotify batch at glibc 2.4, but that doesn't mean I don't think
the *at functions and the *chk functions shouldn't also be in.

Our own survey data of course doesn't include "enterprise apps
running on RHEL/SLES" with such symbols since they're too new.




More information about the lsb-discuss mailing list