[lsb-discuss] LSB Perl version
khoroshilov at ispras.ru
Fri Jan 18 11:31:39 PST 2008
Actually the problem is the current LSB wording prohibits perl-5.10 :
The default installed Perl version shall be 5.8.X with X >= 8.
since 5.10.0 is not "5.8.X with X >= 8".
As a result any distribution providing perl-5.10 cannot be LSB 3.2
compliant while I don't see a reason for this.
If perl-5.10 has not considerable problems with backward compatibility I
would propose to change wording to something like this:
The default installed Perl version shall be 5.X.Y with X.Y >= 8.8.
Markus Rex wrote:
> On Jan 15, 08 07:43:06 -0500, Robert Schweikert wrote:
>> Denis Silakov wrote:
>>> Current LSB Perl specification says: 'The default installed Perl version
>>> shall be 5.8.X, with X >= 8.'.
>>> However, the latest Perl 5.x release is 5.10.0. Shouldn't specification
>>> be changed a little?
>> No. At this point the LSB is still a trailing standard and we evaluate the
>> versions of software included in various distributions. Most if not all
>> distributions currently supply version 5.8 of Perl.
>> Generally we try to avoid forcing distribution vendors into upgrade cycles
>> to be LSB compliant.
> I would agree. We could think about this for LSB 4, but right now
> compatibility to existing distribution is more important than newer perl
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the lsb-discuss