[lsb-discuss] Version number on LSB 3.1 base package?

Dan Kegel dank at kegel.com
Fri Jun 27 05:47:14 PDT 2008


On Fri, Jun 27, 2008 at 5:17 AM, Wichmann, Mats D
<mats.d.wichmann at intel.com> wrote:
>> http://refspecs.linux-foundation.org/LSB_3.1.0/LSB-Core-generic/LSB-Core-generic/pkgdepend.html
>> says "lsb-core-noarch ... shall have a version of 3.0"
>>
>> Is this a typo?
>
> It's not, but perhaps an issue that should be revisited.

Uh-oh.   Have you checked to see if distros are obeying that?
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/source/SRPMS/redhat-lsb-3.1-19.fc8.src.rpm
says
Version: 3.1
Provides: lsb-core-noarch = %{version}

This popped up when we actually tried to add an lsb 3.1
dependency on picasa.

(Incidentally, we're trying an incremental approach, using
an lsb dependency to replace a bunch of explicit dependencies...
but keeping a few explicit dependencies that the lsb doesn't cover.
I know this isn't fair dinkum, but I suspect it will work in practice.
Perhaps it should be supported, as it provides an incentive
for ISVs to start using the LSB for *something* even though it
doesn't cover all the interfaces they need yet.)
- Dan



More information about the lsb-discuss mailing list