[lsb-discuss] Installing 3.0 SDK on 3.1 distro

Stew Benedict stewb at linux-foundation.org
Mon Mar 3 09:10:12 PST 2008


On Mon, 3 Mar 2008, Steve Goetze wrote:

> I've got a SLES 10 390x system.  I can install lsb-sdk-3.0.0-2.s390x.tar.gz,
> but when I run lsbc++, I get the following:
> 
> /opt/lsb/bin> ./lsbc++
> /usr/lib64/gcc/s390x-suse-linux/4.1.2/../../../../lib64/crt1.o: In function
> `_start':
> init.c:(.text+0x28): undefined reference to `__libc_csu_fini'
> init.c:(.text+0x2e): undefined reference to `__libc_csu_init'
> init.c:(.text+0x34): undefined reference to `main'
> init.c:(.text+0x3a): undefined reference to `__libc_start_main'
> collect2: ld returned 1 exit status
> 
> lsb-sdk-3.2.0-4.s390x.tar.gz works fine.
> 
> If this is expected behavior, is there any way to build a 3.0 compatible
> package on a 3.1 distro?
> 
> Thanks,
> --Steve Goetze
> 

This looks an awful lot like what I was seeing looking at another issue 
with lsbcc during 3.1.1:

http://bugs.linuxbase.org/show_bug.cgi?id=1599#c15

I just tried the lsbc++ binary from lsb-build-cc-3.0.3-1.s390x.rpm on our 
SLES10/s390x build host and got similar behavior as you observed with no 
arguments, but if I provided a filename it compiled the file. (just using 
the single binary from ~/, as I didn't want to intefere with autobuilds 
that might be running on the machine).

Although obviously a bug that the command can't run without arguments, are 
you able to compile an actual program with the 3.0 lsbc++?

-- 
Stew Benedict
The Linux Foundation



More information about the lsb-discuss mailing list