[lsb-discuss] Which QT version for LSB?

Wichmann, Mats D mats.d.wichmann at intel.com
Mon Mar 10 06:31:45 PDT 2008


> when we evaluated our problems with QT and the LSB 3.1/3.2
> QT tests, we found out that you cannot pass them with QT 4.3.x,
> for LSB 3.2 you need QT 4.2.x.

> But what do to if you have other software, which needs already
> QT 4.3.x?

> I don't think it is a good idea to have a QT spec and tests,
> which only matches one release and is not compatible with 
> newer one. Where there any discussions how to handle this in
> the past?

It's not intended to require a specific version, as
long as it's above 4.2.x (for 3.2; I forgot which version
3.1 expected in the optional standard, but it is was
something lower).

We need to understand and fix such issues.

More information about the lsb-discuss mailing list