[lsb-discuss] Joint session of LSB and OpenPrinting on the LF Summit

Till Kamppeter till.kamppeter at gmail.com
Wed Mar 19 05:34:57 PDT 2008


Is LSB 4.0 (due by the end of this year) not based on the SLES version 
which comes after 10? If LSB 4.0 is also SLES10-based we cannot change 
much in it and so it would be a 3.3 or even only 3.2.1.

Having SANE only in SLED should not prevent it from being in the LSB, as 
the LSB covers also desktops and not only servers.

    Till

Klaus Singvogel wrote:
> Hi,
> 
> speaking of SLES10:
> 
> Theodore Tso wrote:
>> One thing... given our design goal
>> of keeping LSB 4.0 something which existing enterprise distro's can
>> certify against, can you comment about how many of these items are
>> present in RHEL 5 and SLES 10?
>>
>>     * CUPS 1.2.x interfaces
> 
> Not present.
> 
> The release of cups-1.2.x was done after the package freeze of SLES10.
> As there are tremendous changes between cups-1.1.x and cups-1.2.x,
> e.g. RunAsUser option, I dont have the feeling that we will be able to
> provide cups-1.2.x as an update in any service pack ever.
> 
>>     * New printing functionality of GTK 2.10.x and newer
> 
> We're shipping gtk+-2.8.x in SLES10 only.
> 
>>     * Driver inteface OpenPrinting Vector (OPVP) 1.x
> 
> OPVP is part of EPS ghostscript-8.15.x, which is shipped 
> 
>>     * SANE (Scanner Access Now Easy) scanner driver interface
> 
> SANE is not present in SLES10, but sane is part of SLED10 (the
> equivalent desktop product).
> 
> Here you find the list of all shipped packages in SLES10 (not
> containing SLED10 packages):
> http://www.novell.com/products/linuxpackages/server10/i386/index_all.html
> 
> Regards,
> 	Klaus.




More information about the lsb-discuss mailing list