[lsb-discuss] LSB 4.0 and printing

Theodore Tso tytso at mit.edu
Wed Mar 26 15:23:08 PDT 2008


On Wed, Mar 26, 2008 at 10:34:13PM +0100, Till Kamppeter wrote:
> What can be added without problems is SANE, as this is in every common 
> distro and with the strong trend on multi-function devices it is very 
> important for hardware vendors to make driver packages. It also allows 
> to expand the initiative on distribution-independent driver packages to 
> scanners (including stand-alone devices).
> 
> Doing uplifts, like CUPS 1.1.x -> 1.2.x is not possible as LSB 4.0 is 
> based on the same enterprise distros as 3.2. Why not 3.3 then? We should 
> raise the major number for new enterprise distros as base and the minor 
> for a new LSB based on the same enterprise distros. WDYT?
> 
> Any suggestions on what else to add to the printing requirements?
> 
> We will also talk in Austin on the joint session of LSB and OpenPrinting 
> about that subject.

Well, one option which we can certainly do is to do the work that
requires the newer CUPS and newer GtK libraries as a trial-use module.
This would allow us to do the work, and make sure the specs are in
shape for LSB 4.1/LSB 5.0 (whatever we end up calling it).

If this would encourage printer vendors to step up and sponsor the
work, I would definitely be supportive of such an approach.

      	      		    	       	       - Ted



More information about the lsb-discuss mailing list